mirror of
https://github.com/ZeusWPI/Advent-of-Code-Aggregator.git
synced 2024-12-22 02:09:41 +01:00
29 lines
612 B
Nix
29 lines
612 B
Nix
{
|
|
description = "Zeus AoC 2024";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils }:
|
|
flake-utils.lib.eachDefaultSystem(system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
devShell = pkgs.mkShell {
|
|
name = "Advent of Code 2024";
|
|
packages = [
|
|
pkgs.hyperfine
|
|
pkgs.postgresql_14
|
|
pkgs.ldc
|
|
pkgs.go
|
|
pkgs.dub
|
|
pkgs.zig
|
|
];
|
|
|
|
};
|
|
}
|
|
);
|
|
}
|